Error running Stalled Agents

Supports the detector plugin and any feature or other requests around the plugin.
mictlan
Posts: 6
Joined: Tue Nov 12, 2019 2:31 pm

Re: Error running Stalled Agents

Post by mictlan »

Thanks! I updated to 1.0.0.12 and performed a couple of tests. I'm receiving a different error now, stating that the ScreenConnect service is offline, on machines that I've verified are active in ScreenConnect (one of which I'm actually connected to via ScreenConnect as we speak).

Starting Screen Connect connections to SEANSURFACE, Sending wakeup call
Lets give the wake up call a few seconds to do it's job
Prepare to test agent.
Setting CMD.
run CMD.
Agents online status from Screenconnect is unavailable

Agents ScreenConnect service is Offline, we are unable to use screenconnect to access agent.


We're running ScreenConnect 19.4.25666.7235 with RMM+ 1.0.14.

Looking into it a bit further I'm also finding on the Offline SC Agents tab I'm seeing "No agent data returned by RMM+", and I'm curious if I should reset the Access Key in RMM+, though I'm not seeing where that can also be applied in the Stalled Agent Detector. It's been a short minute since this was first set up.

User avatar
Cubert
Posts: 1522
Joined: Tue Dec 29, 2015 7:57 pm
Contact:

Re: Error running Stalled Agents

Post by Cubert »

Yes let's try that as we are not getting data back from SC.

Under offline LTagents click any agent then right click that agent to open up menu. Select from menu to set RMM+ passcode.

It's the same code for all agents so only have to click any one agent to get menu to reset passcode.

mictlan
Posts: 6
Joined: Tue Nov 12, 2019 2:31 pm

Re: Error running Stalled Agents

Post by mictlan »

Great! 1.0.0.12 appears to have resolved my issue. I don't recall making a change to the access key previous to today, and this was definitely working before, so I'm not sure if I might have made that change months ago while attempting to troubleshoot. Either way, I'm up and running now and have successfully tested a restart of the Automate service through ScreenConnect. Thanks for the help!

User avatar
Cubert
Posts: 1522
Joined: Tue Dec 29, 2015 7:57 pm
Contact:

Re: Error running Stalled Agents

Post by Cubert »

Awesome!

DomoB90
Posts: 20
Joined: Mon Sep 09, 2019 8:19 pm

Re: Error running Stalled Agents

Post by DomoB90 »

I'm at a loss as I'm having the exact same issue. I upgraded the stalled agent plugin since I was getting that error. I restarted the DB agent plugins, closed out Automate, and re-opened it. Still didn't work and gave the error "Agents online status from Screenconnect is unavailable .Agents ScreenConnect service is Offline, we are unable to use screenconnect to access agent." But it's not offline, I'm on the PC right now via ScreenConnect.

I then changed the access key in RMM+ and the plugin but that didn't work. I uninstalled the RMM+ plugin from the instance and re-installed it with a new access key and put that access key in the plugin. That didn't work either. I also get the "No agent data returned by RMM+" under the Offline SC Agents tab as well. I'm on plugin version 1.0.0.12 and Control instance version 19.6.26378.7317. My Automate instance is version 19.0.333 (Patch 12).

I'm unsure where to go from here.

mictlan
Posts: 6
Joined: Tue Nov 12, 2019 2:31 pm

Re: Error running Stalled Agents

Post by mictlan »

I know that I had to wait a little while after upgrading to 1.0.0.12 and re-entering the access key before the "No agent data returned by RMM+" message went away, presumably because the slew of "Patch Remedy Maintenance" scripts needed to be run again before it would update. I made those changes and then checked in a couple of hours later.

User avatar
Cubert
Posts: 1522
Joined: Tue Dec 29, 2015 7:57 pm
Contact:

Re: Error running Stalled Agents

Post by Cubert »

What is happening is that a web call out to the SC service with the ID of the agent is getting a negative response back.

if a negative number is received we show that is minutes offline. If SC says agent is not there then sending the next call (restart LTagent) will also fail.

So to test your agent manually open up MYSQL and run the following queries. Each query will return a piece of data needed to execute the final URL request.

Code: Select all

SELECT SessionGUID FROM plugin_screenconnect_scinstalled WHERE ComputerID = 'xxx'

Code: Select all

SELECT CONCAT(URL,':',Port,'/App_Extensions/8e78224d-79db-4dbb-b62a-833276b46c6e/Service.ashx/WakeGuest') FROM plugin_screenconnect_config

Now open Powershell and using the command below, fill in the 3 pieces of info needed (MYURL, ACCESSCODE, SESSIONGUID) and see what your return value is. If a positive number then online that long in minutes, if a negative number then its how long offline in minutes.

Code: Select all

Invoke-RestMethod -Method Post -Uri 'MYURL' -Body '["ACCESSCODE", "SESSIONGUID"]' -ContentType 'application/json' 

Post Reply