Troubleshooting VSS

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Cubert
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Troubleshooting VSS

Post by Cubert »

Problem:
This article details how to troubleshoot VSS errors.

Cause:
Backups may fail if Microsoft’s VSS framework is in a bad state due to clashes between ShadowProtect and other programs trying to use VSS at the same time (See article on "Understanding VSS and ShadowProtect"), or if necessary system services have been mistakenly disabled. To resolve issues caused by a bad state, the system must be cleaned up before backups will function properly.

Resolution:
If Microsoft's VSS framework and/or some of the VSS writers are in a bad state, you need to clean the system up before your backups will work.

1. Cancel any running backup jobs, ending the ShadowProtect SVC process if necessary.

2. Go to Start | Run and enter "services.msc" - Click OK. Verify each startup type is set correctly:
Navigate to MS Software Shadow Copy Provider. Startup Type should be set to "Manual" if it is not already.
Navigate to Volume Shadow Copy. Startup Type should be set to "Manual"
Navigate to ShadowProtect Service. Startup Type should be set to "Automatic"
Navigate to StorageCraft Shadow Copy Provider. Startup type should be set to "Automatic"
3. Delete all greyed-out devices (non-present “Storage Volume shadow copies” devices) from previous snapshots:
Run the command prompt as Administrator.
Run “vssadmin delete shadows /all”, and select “yes” to delete all.
Run devmgmt.msc to open the Device Manager with the option to show non present devices.
Select “View | Show hidden devices” from the Device Manager.
Scroll down until you see “Storage volume shadow copies” in the list.
If it is not listed, see the previous step. Under “Storage volume shadow copies” a listing called “Generic volume shadow copies” will be shown. The icon next to them will be greyed-out.
Remove these items one at a time by right clicking each item and choosing uninstall. Repeat this process until all greyed-out devices are removed.
NOTE: Do not delete any of the Storage Volumes.
4. Verify state of services:
Go to Start | Run, enter “cmd”, and click OK.
Run the command: “vssadmin list writers”. This will display the state of any VSS-aware applications.
If any of the VSS-aware applications are in an unstable state:
Troubleshoot the individual writer and error.
For Server 2003 or Earlier only: Manually reset the state of the VSS writers.
5. Reboot the system.

6. After rebooting:
Go to Start | Run, enter “cmd”, and click OK.
At the C:\ prompt type “vssadmin list writers” and verify all services are in a stable state. No existing shadow copies should be shown.
Conclusion

Following the steps listed above should clean the system up enough for you to start using backups correctly. Proper VSS interaction is very complex and many backup products leave various components (especially VSS writers) in bad states. This can cause problems for other backup products. If you are using any other backup products, it's very likely that they will corrupt the states of various VSS components. You must always ensure that Windows Backup does not run at the same time as other backup software such as ShadowProtect, Backup Exec, Acronis, etc.

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